[CentOs7]composerのアップデートでエラーがでてアップデートできないときの対処法

CentOS

先の投稿でcomposerのアップデートでコマンドが通らないときの対処法を書きましたが、今度は更新途中でこけてしまう場合の対処法です。

エラーをよく見てみると
Update failed (The zip extension and unzip command are both missing, skipping.
とあります。

zipとunzipコマンドが通らないよ。と言われています。

これも、いくつかサーバを管理していると入れていないパッケージがあるときに起きてしまいます。
なので入れてしまいましょう

インストールが終わったら再度composerの更新コマンドを叩きます。

今度こそ正常に更新が流れます。